'Grading in progress' and limited phone lines

Incident Report for Financial Edge

Resolved

The issues affecting grading functionality due to disruptions with AWS services have now been resolved.

All systems are operating normally, and grading processes should be functioning as expected. We will continue to monitor performance closely to ensure stability.

If you experience any further issues, please contact our support team at support@fe.training.

Thank you for your patience during this time.
Posted Oct 21, 2025 - 12:23 BST

Update

We have been made aware that the earlier issues affecting AWS services may not be fully resolved. As a result, some users may continue to experience intermittent disruptions with grading in Felix and GO.

We are actively monitoring the situation and will provide further updates once we receive confirmation of a complete resolution.

If you encounter any issues, please contact our support team at support@fe.training.
Posted Oct 20, 2025 - 16:09 BST

Update

We are continuing to monitor for any further issues.
Posted Oct 20, 2025 - 13:45 BST

Monitoring

The issue with exam grading has now been resolved following the AWS outage this morning, those that were stuck on pending grading have now been pushed through manually and graded.

Our phone lines have also been restored, we will continue to monitor the situation and update here once fully resolved.
Posted Oct 20, 2025 - 13:45 BST

Identified

Following the AWS outage this morning, we are seeing some degraded performance with some services due to our third-parties. Exams, tryouts and quizzes on our platform may show as 'grading in progress' - we expect this to be resolved once the fault is addressed by AWS and we will re-run all grading that has been impacted during this outage.
Our phone provider is also experiencing mixed issues - we request that where possible you email our teams via Info@fe.training or Support@fe.training and we will be there to assist with sales or support queries.
Posted Oct 20, 2025 - 12:15 BST
This incident affected: Financial Edge Website, Felix, and GO - LMS.