Video showing 'Sorry this video does not exist'

Incident Report for Financial Edge

Postmortem

Summary

Our video hosting provider suffered intermittent issues with video playback for some users. This impacted the Felix platform for some users intermittently. If a user tried to play a video, they may have seen a “Sorry, this video does not exist” error message.

Early attempts to solve the problem by the video host were unsuccessful before normal operations were restored shortly after. The root cause was an underlying player service suffering from performance issues and inefficient load balancing. Traffic surges pushed this service over a healthy capacity, leading to elevated error rates.

Resolution

The outage triggered alerts with the providers alerting function. Work has already begun on replacing an aging component of the player infrastructure and the timeline for the deployment of that update has been accelerated.

In the meantime, changes to the underlying RPC layer have improved performance allowing the infrastructure to handle existing loads more efficiently.

Prevention

To prevent similar incidents from occurring in the future, our video provider are updating the architecture of the internal player services to improve latency and connection handling. This improvement is already in internal testing and should be deployed fully by the end of April.

Posted Apr 25, 2025 - 15:56 BST

Resolved

We're are awaiting the RCA from our video hosting provider to confirm the exact cause of the minor outage that impacted videos on the platform for some users late in the afternoon (BST) on Tuesday 1 April 2025. The postmortem will be updated once this is confirmed to us by the provider.
If you have any issues, please contact our support team via support@fe.training.
Posted Apr 02, 2025 - 14:30 BST

Update

We are continuing to monitor, however we believe this to be resolved. We await formal confirmation from the hosting provider of a full resolution and what the cause of this was with their systems.
If you are still having issues, please contact our support team via support@fe.training.
Posted Apr 02, 2025 - 09:30 BST

Monitoring

A fix has been implemented for the immediate cause of the outage, however while a more permanent resolution is implemented by our video hosting provider, some users may randomly see ad-hoc error messages while trying to view video content.
We will advise once complete resolution is confirmed.
If you continue to have issues, please contact our support team via support@fe.training.
Posted Apr 01, 2025 - 20:45 BST

Identified

We are aware of an intermittent issue impacting some users to have a playback issue to videos on the Felix platform. We have escalated this to our hosting partner for urgent resolution.
Posted Apr 01, 2025 - 18:00 BST
This incident affected: Felix.