Videos erroring - There has been a critical error on this website. Learn more about troubleshooting WordPress.

Incident Report for Financial Edge

Resolved

We can now confirm after a period of testing, this issue has been resolved by the deployed fix.
If you experience any further difficulties, please contact support@fe.training.
Posted Nov 19, 2025 - 13:25 GMT

Monitoring

Our development team have deployed a fix for this error. We will continue to monitor this issue to ensure it has been fully resolved.

Thank you for your patience while this was deployed and resolved.
Posted Nov 19, 2025 - 10:47 GMT

Investigating

Some users are may see the following error when accessing videos on Felix:
"There has been a critical error on this website. Learn more about troubleshooting WordPress."

Our development team are actively investigating the cause of this error.
Posted Nov 19, 2025 - 10:29 GMT
This incident affected: Felix.